Visual Studio .NET - can not install .NET Framework 2.0 or 3.5

Asked By betty rausch on 08-Feb-10 05:35 PM

I have canon software for a powershot A series digital camera.  The software requires 2.0 .NET Framework. When I try to install it says error 0x80131107.... failed assembly for C:/Windows/Microsoft.NET/Framework/v2.050727/Microsoft.VisualBasic.Compatibility.dll


I get the same kind of readings when I try to install 3.5 .NET Framework from my PrintShop 2.0 Deluxe desktop publishing software.


I have .NET Framework 1.1  I have uninstalled it altogether once and reinstalled, because I was told that would work out the kinks and the other frameworks would install, but it didn't help.  I have windows XP service pack 3.

Peter Bromberg replied to betty rausch on 08-Feb-10 06:42 PM
Make sure you have run the installer as an Adminstrator. Look for the log files which will give more details.
mv ark replied to betty rausch on 08-Feb-10 07:50 PM
This could happen to due to multiple reasons besides requiring Admin permissions to install, as reported here - http://social.msdn.microsoft.com/Forums/en/vssetup/thread/8655d21b-259b-449d-a0f4-0b94cdc353a1

If you have Zone Alarm installed (even  if its turned off or disabled), it'll hang the install - http://blogs.msdn.com/quanto/archive/2006/03/31/566191.aspx
Uninstall Zone Alarm before installing the framework.  For more information, check out:   http://www.iisfaq.com/default.aspx?View=A335