WCF/WF - prerequisite for WCF - Asked By tarun on 01-Oct-10 05:56 AM

I want to know that which version of visual studio i need to run WCF application, can i build WCF application in visual studio 2005 or i need newer one.
Sagar P replied to tarun on 01-Oct-10 06:07 AM
Actually WCF is a part of VS 2008 and above but you can use it in 2005 as well for that you have to use the 3.0 templetes in VS 2005.

http://blog.stevienova.com/2007/02/25/net-30-wpfwcf-templates-for-vs2005/
Reena Jain replied to tarun on 01-Oct-10 06:07 AM
hi,

you need to use visual studio 2008 to use the WPF/WCF application.

hope this will help you
Web Star replied to tarun on 01-Oct-10 06:21 AM

You need to install these item on your system.

1) Install Window XP Service Pack 2 or Windows Vista
2) Install Visual Studio 2005
3) Install .Net Framework 3.0 ( If Possilble install full redistruable package of X86 (.Net Framework)
4) Download and install Visual Studio 2005 extensions for .NET Framework 3.0 (Windows Workflow Foundation)
5) Download and install Visual Studio 2005 extensions for .NET Framework 3.0 (WCF & WPF).

Now You dont have to uninstall VS 2005.. You will be coding in vs2005 for .net 3.0 applications..

As and when you finish all installation, Open visual studio 2005 -> Open new project -> .NET framework 3.0-> Here,you will get options of WPF & WCF  etc