ASP.NET - Web application stopped behaving normally after migration from Dedicated servers to Ec2 se

Asked By Manish kharwal on 21-Jun-12 01:20 AM
Earn up to 50 extra points for answering this tough question.
Web application stopped behaving normally after migration from Dedicated servers to Ec2 servers
Old Dedicated Server configuration

system type: 32 bit operating system.
RAM: 3.99 GB Ram
Processor : 1.86 GHZ

New Servers in EC2

system type: 64 bit operating system.
RAM: 3.99 GB Ram
Processor : 2.73 GHZ - 2.31 GHZ

Everything is working fine in our production server.
But as we migrated our web application from old servers to new servers and transferred the entire network traffice to new servers.Site suddenly stopped behaving abnormally.
Sometimes it's super fast
Some times slow.
sometimes normal
some times super slow
and sometimes no response
This all above happens with a time interval or around 2 - 3 minutes.
This went on happening 8 - 10 hours.
Few differences in old and new servers are
Old servers are using II6 and New servers are using IIS 7.5.
We are using exactly the same code in the old and new servers.
Even the ec2 servers are having higher CPU then older servers but still having lower.
But not sure how this is happened.
Please suggests your views...
Vikram Singh Saini replied to Manish kharwal on 27-Jun-12 12:24 PM
Since your EC2 server(s) having higher CPU, you might have installed some memory consuming apps. such as Antivirus, Window Update Application.

Or it could be due to some process running or consuming lot of memory putting all server resources to consume leading to performance loss.

I would recommend you to check from Task Manager, at the moment when site goes abnormal or slow, which process is taking lot of memory at that moment. I can bet that either it can be some virus infection or antivirus trying to update itself and interconnected client pc.

Let us know back the action result.