Visual Studio .NET - Problem with WebForm_DoPostBackWithOptions?

Asked By Paddy Mac on 03-Oct-05 06:04 AM
I have a link button that opens another web form using PostBackUrl.

This works on my local machine but not on the server.  Anyone know why?

I get a javascript error 'WebForm_DoPostBackWithOptions is undefined'

WebForm_DoPostBackWithOptions - Asked By Sunitha Nambari on 03-Oct-05 06:53 AM

hi,

  1. I think u  missed runat=server property.
  2. In Web.config file,remove the http handler "clear"

Regards,
Suneetha

On your remote machine - Asked By Aarthi Saravanakumar on 03-Oct-05 07:03 AM

make sure that the javascript to cause the Client side postback is emitted,
Check the viewsource and search for DoPostBackWithOptions.
If the js is not emitted, the client side scripts may not be copied to the correct folder.
In that case use aspnet_regiis -c to install the client scripts

I have the - Asked By Paddy Mac on 03-Oct-05 07:03 AM

runat=server on the button

<asp:LinkButton ID="LinkButton1" runat="server" Font-Bold="False" Font-Names="Verdana" Font-Size="7pt" PostBackUrl="~/BFFileDetails.aspx">VIEW FILE</asp:LinkButton></td>

And my web.config file does not have the http handler 'clear'.  I'm not sure if there is a configuration problem on the web server?  I have pasted my web.config below.

<?xml version="1.0"?>
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
	<connectionStrings>
		<add name="PilotAConnectionString" connectionString="Data Source=AX7WEBDEV;Initial Catalog=PilotA;Integrated Security=True" providerName="System.Data.SqlClient"/>
	</connectionStrings>
	<system.web>
		<pages styleSheetTheme="White"/>
		<customErrors mode="Off"/>
		<compilation debug="false">
			<assemblies>
				<add assembly="eWorld.UI, Version=1.9.0.0, Culture=neutral, PublicKeyToken=24D65337282035F2"/>
				<add assembly="CrystalDecisions.Web, Version=10.2.3600.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304"/><add assembly="CrystalDecisions.CrystalReports.Engine, Version=10.2.3600.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/><add assembly="CrystalDecisions.ReportSource, Version=10.2.3600.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/><add assembly="CrystalDecisions.Shared, Version=10.2.3600.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/><add assembly="CrystalDecisions.ReportAppServer.ClientDoc, Version=10.2.3600.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/><add assembly="CrystalDecisions.Enterprise.Framework, Version=10.2.3600.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/><add assembly="CrystalDecisions.Enterprise.InfoStore, Version=10.2.3600.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/></assemblies></compilation>
		<authentication mode="Windows"/>
		<identity impersonate="True"/>
		<globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
		<siteMap defaultProvider="XmlSiteMapProvider" enabled="true">
			<providers>
				<add name="XmlSiteMapProvider" description="SiteMap provider which reads in .sitemap XML files." type="System.Web.XmlSiteMapProvider, System.Web, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" siteMapFile="web.sitemap" securityTrimmingEnabled="true"/>
			</providers>
		</siteMap>
		<httpHandlers><add verb="GET" path="CrystalImageHandler.aspx" type="CrystalDecisions.Web.CrystalImageHandler, CrystalDecisions.Web, Version=10.2.3600.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/></httpHandlers></system.web>
</configuration>