ASP - General error Unable to open registry key

Asked By Shabbir Kanchwala on 20-Dec-06 05:55 AM
Dear All,
              I am getting following error

Microsoft OLE DB Provider for ODBC Drivers error '80004005'

[Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0xaec Thread 0x11a0 DBC 0x252c4f3c Jet'.

/ecomforum/inc_header.asp, line 111


How do I resolve it?

Thanks and Regards
Shabbir

check this link - sundar k replied to Shabbir Kanchwala on 20-Dec-06 06:19 AM


"[Microsoft][ODBC Microsoft Access Driver]General error Unable to open
registry key 'Temporary (volatile) Jet DSN for process"

This error can happen when you set up ASP development environment on a newly installed Windows XP system. Here are possible causes for this error, which happens when you try to open a Jet DSN connection (or any connection to a MS Access database) from an ASP (or other) script:

1. The webserver environment needs "write" permission to the directory where the Access database resides. So, set permissions first. Go to Windows Explorer, Tools, Folder Options, View and turn off the very last entry in the list ("Use simple file sharing") if you haven't already done so.

2. Now, you'll have a "Security" tab when you right-click on a folder.  Make sure you give write permission to the folder with the MS Access database to the "IUSR_***" account (with *** being your computer's name). This account is used by IIS, per default, to evaluate permissions for the default access to your local PWS website and scripts.

3.You can create your own User account by the way and set it as default for anonymous access of PWS. To do this, go to Control Panel, Administrative tools, Internet Information Server, expand "local computer," right-click on Websites (if you don't have this, add IIS from your Windows XP Pro CD.  If you have Windows XP Home... tough luck you can't run a webserver, you have to upgrade.)  Select "Properties," Directory Security, "Edit." Here you see the default account and logon.  You can create another user account (under "Control Panel," "User Accounts") with another password and enter this here.  BUT you don't have to do all this to take care of the error above; IUSR_<machine name> is fine for now. I digress...

4.Give the same user IUSR_<machine name> (or whatever is the default account) access to the TEMP directory of Windows. MS Access might need to write some stuff there.

5.Give the same account write permission in MS Access itself.  These permissions can be reset by MS Access if you compact and repair the database so keep in mind to refresh this permission as necessary.

6.If you still get the error "[Microsoft][ODBC Microsoft Access Driver]General error Unable to open
registry key 'Temporary (volatile) Jet DSN for process", check that the database is really in the directory referenced by the DSN or the connection string in your ASP file! Also, check for misspellings in the file name. This was the reason for the error when I ran into it earlier this week.

Hope this helps...


Check the source link below,
http://www.attention-to-details.com/newslog/38n-temporary-volatile-jet-dsn-for-process.asp

Reply for the Post - Shabbir Kanchwala replied to sundar k on 20-Dec-06 07:11 AM

Dear Venkatesh,
                         Thank you very much for the quick response, but is their any more solutions which get this error resolved?

Thanks again

Thanks and Regards
Shabbir

Troubleshooting guide for 80004005 errors in Active Server Pages and Microsoft Data Access Components

K Pravin Kumar Reddy replied to Shabbir Kanchwala on 20-Dec-06 07:26 AM

Troubleshooting guide for 80004005 errors in Active Server Pages and Microsoft Data Access Components

This article lists various 80004005 error messages, the most frequent causes of the error messages, and troubleshooting steps to resolve them. The 80004005 error is received by Microsoft Data Access Components (MDAC) in Active Server Pages, including Microsoft ActiveX Data Objects (ADO), OLE DB, and the Remote Data Service (RDS). Although this article assumes that you are using ADO within an Active Server Pages (ASP) page, the causes and many of the troubleshooting steps are applicable to any environment in which you use ODBC for data access.

reference

http://support.microsoft.com/kb/306518

see this link - Ravichandran K replied to Shabbir Kanchwala on 20-Dec-06 08:12 AM

hi,
use this link you will get an idea....

http://support.microsoft.com/kb/306518

http://support.microsoft.com/kb/238971
Unable to open registry key 'Temporary (volatile) Jet DSN..... - mv ark replied to Shabbir Kanchwala on 20-Dec-06 11:04 PM
IUSR_<machineName> must have read and write permissions not only on the MDB file, but also on the folder in which it resides, and in some cases the system %TEMP% folder.

Check this KB article for resolving issue  - http://support.microsoft.com/default.aspx/kb/315456