Exchange Server - MSExchangeOMA 1503 Message: The remote server returned an error: (403) Forbidden.

Asked By Norbert Peter on 17-Jul-14 10:12 AM
I am trying to setup iphones on exchange without ssl on sbs 2003. OMA is not working when I logon. The message I get:
A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.

Event viewer:

Event Type: Error
Event Source: MSExchangeOMA
Event Category: (1000)
Event ID: 1503
Date:  16/03/2010
Time:  12:07:43
User:  N/A
Computer: SERVER001
Description:
An unknown error occurred while processing the current request:
Message: The remote server returned an error: (403) Forbidden.
Source: Microsoft.Exchange.OMA.ExchangeDataProvider
Stack trace:
   at Microsoft.Exchange.OMA.ExchangeDataProvider.OmaWebRequest.GetRequestStream()
   at Microsoft.Exchange.OMA.ExchangeDataProvider.ExchangeServices.GetSpecialFolders()
   at Microsoft.Exchange.OMA.ExchangeDataProvider.ExchangeServices..ctor(UserInfo user)

Message: Exception has been thrown by the target of an invocation.
Source: mscorlib
Stack trace:
   at System.Reflection.RuntimeConstructorInfo.InternalInvoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean isBinderDefault)
   at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)

Message: Exception of type Microsoft.Exchange.OMA.DataProviderInterface.ProviderException was thrown.
EventMessage:
UserMessage: A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.
Source: Microsoft.Exchange.OMA.UserInterface
Stack trace:
   at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)
   at System.Web.SessionState.SessionStateModule.RaiseOnStart(EventArgs e)
   at System.Web.SessionState.SessionStateModule.CompleteAcquireState()
   at System.Web.SessionState.SessionStateModule.BeginAcquireState(Object source, EventArgs e, AsyncCallback cb, Object extraData)
   at System.Web.AsyncEventExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


I am tring to resolve OMA issue for more than a week. I was getting different errors earlier. Had blank page when I logged on, had .NET errors etc. I went through all the possible steps I found on microsoft website.

http://support.microsoft.com/kb/842119
http://support.microsoft.com/kb/817379
http://support.microsoft.com/kb/817311
http://support.microsoft.com/kb/898131
http://support.microsoft.com/kb/817379

I reset IIS folders and ran CEICW countless times. Everything is working except OMA. There is Sharepoint installed on sbs which in my opinion could cause the problem. Went through this as well:
http://blogs.technet.com/asksbs/archive/2008/08/12/default-settings-of-default-website-virtual-directories-under-default-website-and-companyweb-on-a-sbs-2003-server.aspx
Any help would be appreciated.
Jessica Szempruch replied to Norbert Peter on 16-Mar-10 10:58 PM
For clarification, are you receiving the error, "A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator," on the iPhone? If so, ensure that you have SSL turned off on the iPhone, and modified IIS on the server so that SSL is not required. By default, the iPhone will connect to the URL you provide using SSL, even if you typed http:// in the URL. Another thing to check is to make sure Outlook Mobile Access is enabled under the user account properties in Active Directory.
Norbert Peter replied to Jessica Szempruch on 17-Jul-14 10:14 AM
Thank you for your reply. The issue was nothing to do with the iphones. Outlook mobile access was not working. So when I browsed http://localhost/oma or http://servername/oma I was getting an error message. I set up iphones on many servers before but not sbs with sharepoint installed. Basically I had to modify web.config for OMA based on the following:

http://support.microsoft.com/default.aspx?scid=kb;en-us;837376

And the other thing was based on this article:

http://support.microsoft.com/kb/817379

I did all of the instructions mentioned above but I still could not get it working. I was trying different things with exchange-oma virtual directory and turned out the registry setting was not correct. In the article it says the value has to be /exchange-oma but that did not work. Had to remove the forward slash to get it working.