This Error means that HTTP request is failed. It can occur due to various reasons. To find the root cause please try following
On a browser on client type http://server_IP_address/virtual directory alias/sscesa30.dll.
If you can’t access this, it meant that connection from device to IIS is broken.
If you can access this, it meant that there is issue in getting connected /access permission etc from IIS to SQL Server/Publication.
1. Check - SQL Server agent is running.
2. Windows firewall is not blocking Web Services. For IIS 5.1, follow these steps:
In control panel-> windows firewall -> Advanced -> Settings -> Services , check the Web Server(HTTP) option.
Norton or other tool can prevent snapshot access to client. Check the settings. Try turning off the firewall.
3. Ensure that ASP.NET is registered with IIS. To do this, go to the Windows\Microsoft.Net\Framework\<version directory> in the system drive and execute <aspnet_regiis.exe -i> on the command line.
Give IUSer_ServerName a permission on publication. As you are not getting this error all the time, it does not seem a permissions issue. It seems a connectivity issue.
As this works fine for 4 month and then you installed June CTP. Try recreating the virtual directory , publication and subscription.
If it does not resolve the issue – please provide details.
1. Are you using SQL Server, IIS on same machine or on different.
2. What authentication mechanism you are using on IIS/SQL machine?
3. When you get error at that time can you access http://server_IP_address/virtual directory alias/sscesa30.dll.
4. When you get error, verify the connectivity between client and server (is it working)