Windows Server - DPM 2010 crash, event id 999 - Asked By Kostas Vatseris on 28-Mar-11 03:47 AM

Hello,

We have a Data Protection Manager 2010 and was working well for some months.
Yesterday, we delete a protection group that protected sql databases.
During the deletion, DPM crashes and from then, the DPM Management Console doesn't open.
The problem is that the DPM service is unable to start.
Looking at the Event Viewer the error that appears, is the following:

Source: DPM Event ID: 999

The description for Event ID 999 from source MSDPM cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

An unexpected error caused a failure for process 'msdpm'. Restart the DPM process 'msdpm'.

Problem Details:

<FatalServiceError><__System><ID>19</ID><Seq>0</Seq><TimeCreated>28/3/2011 7:45:53 πμ</TimeCreated><Source>DpmThreadPool.cs</Source><Line>163</Line><HasError>True</HasError></__System><ExceptionType>SEHException</ExceptionType><ExceptionMessage>External component has thrown an exception.</ExceptionMessage><ExceptionDetails>System.Runtime.InteropServices.SEHException: External component has thrown an exception.

at RaiseException(UInt32 , UInt32 , UInt32 , UInt64* )

at ATL.CSid.{ctor}(CSid* , UInt16* pszAccountName, UInt16* pszSystem)

at Microsoft.Internal.EnterpriseStorage.Dls.Engine.CServiceModule.InitializeSecurity(CServiceModule* )</ExceptionDetails></FatalServiceError>

 

the message resource is present but the message is not found in the string/message table



Any help will be highly appreciated.
Ravinder Jamgotre replied to Kostas Vatseris on 06-Apr-11 10:02 AM
Seems like a corrupt SQL DB try running DBCC checkdatabae command and see if any errors persists, maybe not at table level but at data level.

Have you got a SQL backup pre-error? if so, restore this.

Try restarting the DPM service if failing, reboot machine in safe mode (that's F8 at BIOS) and try.

Let me know.