IIS - 'MSExchangeSyncAppPool' suffered a fatal communication error with the

Asked By MOHAMMED on 03-Apr-11 06:52 AM
I am using exchange server 2010,IIS 7
and in the event log i am getting the following Warring event ID 5011 with the following msg

Log Name:      System
Source:        Microsoft-Windows-WAS
Date:          4/3/2011 10:49:21 AM
Event ID:      5011
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      Domain.com
Description:
A process serving application pool 'MSExchangeSyncAppPool' suffered a fatal communication error with the Windows Process Activation Service. The process id was '4876'. The data field contains the error number.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-WAS" Guid="{524B5D04-133C-4A62-8362-64E8EDB9CE40}" EventSourceName="WAS" />
    <EventID Qualifiers="32768">5011</EventID>
    <Version>0</Version>
    <Level>3</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-04-03T07:49:21.000000000Z" />
    <EventRecordID>26708</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>System</Channel>
    <Computer>Domain name</Computer>
    <Security />
  </System>
  <EventData>
    <Data Name="AppPoolID">MSExchangeSyncAppPool</Data>
    <Data Name="ProcessID">4876</Data>
    <Binary>6D000780</Binary>
  </EventData>
</Event>

Ravinder Jamgotre replied to MOHAMMED on 03-Apr-11 05:14 PM
Mohammed,

Have you checked that application pool is running/started?

To check this browse to the following in IIS7, run IIS Manager in Administrative Mode:

Right-click Internet Information Services (IIS) Manager and select Run as administrator.

In the Connections pane, expand the server node and select Application Pools.

In Features View, the Status column for the application pool will indicate Started if the application pool has started.

if this does not help then  try and check the ActiveSyncConnectivity using the Exchange Management Shell, type the following Test-ActivesyncConnectivity... if you receive an error that states 503 Server Unavailable you may need to install exchange 2010 service pack 1...

if this does not help then try the outlook synchronisation test abd checking the autodiscover facility offered in the new ms exchange servers.

Let me know if I can help further mate. I have successfully setup Exchange 2010 and running it remotely through https on owa and outlook using RPC.

Ravinder

MOHAMMED replied to Ravinder Jamgotre on 04-Apr-11 01:24 AM
thz for reply, i did check ms activesync with https://testexchangeconnectivity.com/ and test was succesfull,and also the MSactivesyncapplication pool is also in started state.but still i getting a warring log with event ID 5011 and the latest one are


A process serving application pool 'MSExchangeSyncAppPool' exceeded time limits during shut down. The process id was '7644'.

A process serving application pool 'MSExchangeSyncAppPool' suffered a fatal communication error with the Windows Process Activation Service. The process id was '2284'. The data field contains the error number.
Ravinder Jamgotre replied to MOHAMMED on 04-Apr-11 04:42 AM
Hi Mohammed,

Have you tried to increase the timeout in IIS in WebSite >Advanced Settings >Connection timeout ?

Also could be a ASP.net error somewhere, what updates or hot-fices for exchange 2010 have you applied. I believe SP1 is released for Exchange 2010, apply this.

Also the application pool, does it have the correct access rights for the user starting the service. ie Domain Administrator, System or Network.

Let me know.