IIS - problem - Asked By sunny on 09-Oct-11 01:28 AM

Server Error in Application "DEFAULT WEB SITE"Internet Information Services 7.5

Error Summary
HTTP Error 404.4 - Not Found
The resource you are looking for does not have a handler associated with it.

Detailed Error Information
Module IIS Web Core
Notification MapRequestHandler
Handler Not yet determined
Error Code 0x80070002
Requested URL http://localhost:80/test1.asp
Physical Path C:\inetpub\wwwroot\test1.asp
Logon Method Anonymous
Logon User Anonymous
 
Most likely causes:
•The file extension for the requested URL does not have a handler configured to process the request on the Web server.
 
Things you can try:
•If the file extension does not have a handler associated with it, add a handler mapping for the extension.
•Verify that the handler associated with the file extension is properly installed and configured.
•Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here.
 
Links and More Information
This error means that the Web server does not recognize the file extension of the requested resource. A module handler is not configured on the Web server for this extension. If the file extension being denied is required by the Web server, add the appropriate handler for the file extension.
View more information »

Peter Bromberg replied to sunny on 09-Oct-11 09:17 AM
Looks like you haven't enabled classic ASP in IIS.
Anoop S replied to sunny on 09-Oct-11 10:06 AM
Reason
The file name extension of the requested URL does not have a handler that is configured to process the request on the Web server.

To resolve this problem, add a handler mapping for the file name extension of the requested URL. For example, follow these steps if you want to add a StaticFile handler mapping:
  1. Start IIS Manager. To do this, click Start, click Run, type inetmgr.exe, and then click OK.
  2. In IIS Manager, expand server name, expand Web sites, and then click the Web site that you want to modify.
  3. In Features View, double-click Handler Mappings.
  4. In the Handler Mappings pane, right-click the StaticFile handler mapping, and then click Edit.
  5. In the Edit Module Mapping dialog box, type * in the Request path box, and then click OK.
Devil Scorpio replied to sunny on 09-Oct-11 03:39 PM
Hi Sunny,

Cause

IIS security settings have not been modified from their default settings. This will deny the downloading of the required CCR.EXE.CONFIG file for the end user's clients.

Environment

Controller hosted on Windows 2008 server.

Resolving the problem

Reconfigure IIS to allow the download of .config files.


Steps:

  1. Open the folder C:\Windows\System32\inetsrv\config
  2. Launch Notepad.exe and edit the file applicationHost.config
  3. Search for ‘requestFiltering’ section
  4. Modify the value for ‘.config’ to ‘true’:
In other words, modify the line to read: <add fileExtension=".config" allowed="true" />